Post pics of your RE installs...

General car audio discussion area.
User avatar
MegaloRESE15
New Member
Posts: 311
Joined: Sun Feb 12, 2006 10:59 am
Location: The Colony, TX

Postby MegaloRESE15 » Thu Dec 28, 2006 6:36 pm

wow that is big..also heavy lookin
:cwm20:
TERMLab 140.3
User avatar
Luke12390
New Member
Posts: 39
Joined: Tue Aug 22, 2006 3:24 am
Location: Sydney, Australia

Postby Luke12390 » Thu Dec 28, 2006 7:16 pm

The sub itself weighs 32kg. With the enclosure its about 85kg :)
User avatar
CPL DOZIER
Posts: 43
Joined: Tue Jun 27, 2006 7:58 pm
Location: Birmingham, Al.

Postby CPL DOZIER » Thu Dec 28, 2006 9:31 pm

I know my xxx 12's weighed in at 92 lbs in the box. I had to ship one back for repair.
IF YOU CAN'T CONVINCE THEM.......CONFUSE THEM.
User avatar
Luke12390
New Member
Posts: 39
Joined: Tue Aug 22, 2006 3:24 am
Location: Sydney, Australia

Postby Luke12390 » Fri Dec 29, 2006 12:18 am

Yeah, the shipping weight of mine was 48kg. Its some awesome packaging but.
User avatar
almond
New Member
Posts: 2
Joined: Mon Sep 04, 2006 11:40 am
Location: chandler, az

Postby almond » Fri Dec 29, 2006 1:12 am

i still need to do some button up work, but it's never done so here is what i have so far.
number 1
number 2
number 3
info is on the you tube vid number 1.
User avatar
90accordman
New Member
Posts: 74
Joined: Mon May 01, 2006 5:57 pm
Location: Fresno California

Postby 90accordman » Wed Jan 10, 2007 3:23 am

almond wrote:i still need to do some button up work, but it's never done so here is what i have so far.
number 1
number 2
number 3
info is on the you tube vid number 1.


lovin the 3rd video
Under Construction
User avatar
Member02
Posts: 2891
Joined: Wed Dec 12, 2001 8:07 pm
Location: viginia beach, VA
Contact:

eh

Postby Member02 » Wed Jan 31, 2007 7:23 pm

here's my latest creation using RE's favorite sub!

Image

Image


and here's my video of it in action!

http://www.youtube.com/watch?v=F5Ur0W--As8
User avatar
MegaloRESE15
New Member
Posts: 311
Joined: Sun Feb 12, 2006 10:59 am
Location: The Colony, TX

Postby MegaloRESE15 » Wed Jan 31, 2007 7:42 pm

cool vid


but Where'd the guts go of the amp :confused:
:cwm20:

TERMLab 140.3
User avatar
Member02
Posts: 2891
Joined: Wed Dec 12, 2001 8:07 pm
Location: viginia beach, VA
Contact:

Postby Member02 » Wed Jan 31, 2007 7:56 pm

MegaloRESE15 wrote:cool vid


but Where'd the guts go of the amp :confused:

what'ddya mean?
User avatar
killerbass96
Posts: 1237
Joined: Sat Sep 20, 2003 10:34 pm
Location: indy
Contact:

Postby killerbass96 » Wed Jan 31, 2007 10:01 pm

well id say.... ya do need practice more with vinyl ;)
nice video tho....

looks like ya used regular glue... ya can see the lines..... id say next time ya try vinyl try to add some foam under it to stretch it out alittle beter... and lots of spray glue ;)

my hardest parts are curves! also use a hole punch to cut out the vinyl around the screw holes so they dont bite and stretch the vinyl...
99 civic EX coupe, black.
upgrading under progress
single SX12inch sub, with a (jbl 600.1) ported 34hz.
future setup. FIaudio BTL 12inch sub, RF T2 amplifier.

Return to “Car Audio”

Who is online

Users browsing this forum: Google [Bot] and 1 guest