Page 1 of 1

'92 Ranger

Posted: Fri Nov 17, 2006 9:19 am
by Nigel
well, I finally think I'll Start a project log. What I've got is a '92 Ford Ranger XLT ext. Cab. w/ the 4.0 litre V6 engine. So far, all I've done is some audio upgrades (aren't complete yet) and plan on doing more in the future.

Equipment List:
Source Unit: Alpine CDA-7897
Component Set: JL Audio VR 525-CSi
Subwoofer: Oz Audio Matrix Elite 12.4
Component Amplifier: JBL GTO 75.2 II
Subwoofer Amplifier: JBL GTO 601.1 II
Interconnects: Streetwires LN-2
Distrobution Block: Phoenix Gold
Power Wire: Stinger & SWX

Hope you enjoy,

Nigel



Here are some pics (some you've seen already):

Some Of the Equipment going in:
Image
Image
Image
Image

New Interconnects being installed up front (and old ones coming out):
Image

Front Done, just need to put trim panels back:
Image

New Interconnects on their way and old ones coming out:
Image

Old Interconnects and Rem. Turn on lead (being Removed):
Image

New Interconnects (Streetwires LN-2) run to rear of cab:
Image

Posted: Tue Nov 21, 2006 12:25 pm
by Nigel
here are some finished pics. I forgot my camera this weekend when I went to the old man's to work on the truck, so I used his digicam. He is going to burn the pics to a cd for me and send it my way. But that probably won't be for a while since he leaves for italy in a couple of days. So here are the finished pics.

Nigel



Image

Image

Image

Image

Image

Imagehttp://i131.photobucket.com/albums/p282/cx1helmer/DSCI0020.jpg

Image

Image

Image

Image

Posted: Tue Nov 21, 2006 12:27 pm
by Nigel
As you can tell, I still need to carpet the subwoofer box, but I didn't have the carpet nor the time to do that over the weekend so it will need to be redone at a later date. As well when the truck is running I am getting a very light fuzz through my tweeters so I will need to look into that as well.

Nigel

Posted: Fri Nov 24, 2006 6:04 pm
by phrozen_lad
hi,just wondering what you think of the OZ sub? thinking of getting 2x me.15's to replace my SE's :)

Posted: Sat Nov 25, 2006 11:38 am
by Nigel
I personally like the OZ. It gets plenty loud for my tastes and sounds quite good as well.

Nigel

Got a New Vehicle

Posted: Thu Feb 01, 2007 7:03 pm
by Nigel
Well,

The Ranger was getting old. It was starting to rust. And the mileage was getting up there. So, on a whim, I went out and bought myself a new truck. Therefore, all of the stereo equipment I just put in this truck is all coming out and going into My new truck.

My new Truck is a 2003 Chev. S-10 ext. cab. w/ 4.3 litre V6. Oh, and I've already ordered a 3" lowering kit for it. Just waiting for it to come in.

Nigel